Wordpress 3.2 : a major move

wp 3.2 is out!
Wordpress 3.2 is a new major release, like 2.9 was.

But this time, not only because this new version of Wordpress introduces very exciting features, but also because wordpress 3.2 drops backward compatibility with legacy browser (ie6), PHP engine 4 (PHP4) and Mysql 4.x (5.0+ required).

Some PHP and Mysql restrictions

Indeed, if you try to install a recent wordpress (3.2 or greater), you may face some error messages. Before proceeding, make sure your hosting plan offers :

  • PHP 5.2.4 or greater (old requirement was PHP 4.3 or greater since WordPress 2.5 )
  • MySQL 5.0.15 or greater (old requirement was MySQL 4.1.2 or greater since WordPress 2.9 , MySQL 4.x prior to WP2.9)

If you get a message like:

Your server is running PHP version 4.4.9 but WordPress 3.2.1 requires at least 5.2.4.

Don’t panic, you may keep your hosting plan by tweaking some settings. Indeed, some allow to “force” the version of PHP used. For instance, Alwaysdata will provide such an option in your admin panel:

php5Other hosting companies will allow to force php5 by using a specific command to be inserted in the “.htaccess” file located at the root of the web directory (usually “www”): “AddType x-mapp-php5 .php” for 1and1, “AddHandler x-httpd-php5 .php” for GoDaddy, “SetEnv PHP_VER 5″ for OVH, …

A bunch of new features

Wordpress 3.2 introduces a deep change in the backend: lighter, faster, easier to use… Just try by yourself or watch the video below.

For copywritters, a new editing mode where you get a “blank sheet”, without any disburbing icon or menu around.

And a brand new HTML5 theme, named Twenty Eleven, that embed nice features like the ability to have multiple rotating header images to highlight all of your favorite photos.

For all of this, have a look at the Wordpress.tv video:

Introducing WordPress 3.2 "Gershwin"

Introducing WordPress 3.2 "Gershwin"

This movie requires Adobe Flash for playback.

6 Responses to “Wordpress 3.2 : a major move”

  • Adrien:

    Bonjour,
    Je suis passé à la version 3.2.1 de Wordpress et même avec votre manip sur mon OVH, j’ai toujours ce message qui apparait :

    Your server is running PHP version 4.4.9 but WordPress 3.2.1 requires at least 5.2.4.

    Merci d’avance pour votre aide.

  • J’ai installé wordpress 3.2.1 hier sur un hébergement mutualisé OVH, j’ai fait comme ça (créé un fichier .htaccess dans le dossier principal de wordpress, contenant la ligne “SetEnv PHP_VER 5″), et cela a fonctionné.

    Je soupçonne que ton fichier .htaccess n’est pas actif (mauvais nom ou dossier). Pour le vérifier, le plus simple est d’ajouter une ligne contenant simplement le texte “error” : ça doit engendrer une erreur 500 lors de l’affichage de la page. Si ce n’est pas le cas, c’est que le fichier .htaccess n’a pas le bon nom, ou bien n’est pas situé au bon endroit.

  • Adrien:

    Ok, c’est good en faite, mon fichier .htaccess avait sauté.

    En faite, visiblement, il saute dès que je demande à changer format des URL dans l’interface Wordpress -> Réglages/permaliens.

    Une idée ?

  • @Adrien: voir si lors de la modification des permalinks, wordpress n’essaie pas de modifier le htaccess… et le casse. Pour eviter cela, tenter de mettre les droits en lecture seule.

  • Adrien:

    ah oui je pense que c’est ca.
    comment je le passe en lecture seule ?

  • [...] Edit the .htaccess file to force 1&1 to use PHP5 by adding “AddType x-mapp-php5 .php” (thanks TECHNOBLOG) [...]

Leave a Reply